Age of Empires 2 Definitive Edition for Mac

Yes! After countless requests, its here… Age of Empires 2 Definitive Edition for Mac. We have added the first DXVK supported game in history of Porting Kit and many more will follow from now on. Now the way is open to Directx10/11 games, a new era of goodness has been began! I tested  Age of Empires 2 Definitive Edition even on Silicon Mac and works gorgeous. The video below is also made from my Silicon M1 Mac Mini with 16GB. Check out the video tutorial and start the fun! Played also a multiplayer game without issues and I even won :D.

Download Porting Kit from the Porting Kit download page…

Basic Portingkit Install Instructions Steam games:
1. Get the cheap steam serial of Age of Empires 2 Definitive Edition here from Green Man Gaming
2. Always read the “notes” of the game description first for additional steps!
3. Go to the library server tab and select the game you want to install and click “Install”
4. Portingkit will create the wrapper and locate your setup file in your download folder
5. The installation of the game will start, run through the install wizard.
6. Porting kit will say it has finished successfully.
7. Go to your local library tab and select the game and click “play”!
9. Login into the Windows Steam and activate the serial and download and play!!

Alternatively there is also Parallels Desktop (a very easy to use Virtual Machine with Windows 11 (free trial of 14 days)) where the game will work fine as well. More info about that up here: https://www.paulthetall.com/parallels-desktop/

Game description:
Age of Empires II: Definitive Edition celebrates the 20th anniversary of one of the most popular strategy games ever with stunning 4K Ultra HD graphics, a new and fully remastered soundtrack, and brand-new content, “The Last Khans” with 3 new campaigns and 4 new civilizations. Explore all the original campaigns like never before as well as the best-selling expansions, spanning over 200 hours of gameplay and 1,000 years of human history. Head online to challenge other players with 35 different civilizations in your quest for world domination throughout the ages.

Go to the Porting Kit game page up here…

Love the work we do? Become a Patron… and get extra Tiers!

About Post Author

paulthetall

Happy
Happy
0
Sad
Sad
0
Excited
Excited
1
Sleepy
Sleepy
0
Angry
Angry
0
Surprise
Surprise
0

42 thoughts on “Age of Empires 2 Definitive Edition for Mac

  1. Hi,

    Having just followed the above, the game fails to load, with the error message coming up as:

    “Age of Empires II: Definitive Edition minimum specification requires a DirectX 11 compatible display adaptor. This computer does not meet that requirement.”

    My mac specifications are as follows:

    Macbook air 2013 : OS : El Capitan 10.11.6 (15G22010)

    1.7 GHz Intel Core i7

    8 GB 1600 MHz DDR3

    Intel HD Graphics 5000 1536 MB

    Any advice you can give me is appreciated, if I cannot get your port to work I will have to return the game for a refund through Steam,

    Thanks

    Robbie

  2. Hi Paul, thank you so much for getting AoE2DE to work. Just when we were thinking we’d have to give up our AoE2FE install, this comes along. What an upgrade!

    Two things we’ve come across: firstly, when steam loads to a white screen (basically every time we open), it seems to come with a performance hit – mostly this is on older machines, we’re talking 2013-2015 MBPs. The work around we have for this atm is to rerun steamsetup.exe every time we run the game.

    Secondly, 2013 15″ MBP’s seem to have an issue with DXVK. I’m not really sure how to go about debugging this, but it works fine on 10.14, but 10.15 and 11 come with no – I posed about this here when trying crossover, https://www.codeweavers.com/compatibility/crossover/forum/age-of-empires-ii-definitive-edition?msg=235470#c7

    If you’d like me to submit this info somewhere else, please let me know.

  3. Hi! We found a fix for the white screen. Please reinstall the port one more time. The fix should then automatically applied in the port.

  4. Part 1 – fantastic. Thank you so much!
    Part 2, for some reason the version of DXVK \ MoltenVK went backwards:
    the older wrapper has: [mvk-info] MoltenVK version 1.1.1. Vulkan version 1.1.162
    vs in the newer one [mvk-info] MoltenVK version 1.1.0. Vulkan version 1.1.154.

    This was causing me to get “… minimum specification requires a DirectX 11 compatible display adapter” popup error. There was a bit more in the log file, but to cut the story short, replacing the MoltenVK and Vulkan folders in Shared Support\Include and libMoltenVK.dylib with the previous newer version made it work, while also seemingly keeping the Steam window happy.

  5. Hi, encountered the same issue as comebacktomorrow with DX11 display adapter popup. Tried to replace the MoltenVK/DXVK to newer version as suggested but missed some steps I guess (could not get the proper version libMoltenVK.dylib) so it did not help. If it does resolve the issue however, could the old wrapper versions be reinstated please? Thanks a lot!

  6. Hey that’s great – I’m replying here just to keep everything in the same place: That’s interesting because I’m rocking an Nvidia GPU (in additional to Intel). For what it’s worth, I ended up trying out DXVK 1.2.1 as a replacement for AJAX’s sake, and it ran with no problems – if anything it might run a little better. Bonus perk, VXVK 1.2.1 also works with the GT750M (Late 2013 MBP 15″) on OS’s higher than 10.14 (well, specifically, 11.2.2).

    Now I have no need to dual boot!

  7. I load it onto my late 2014 Mac mini w/ 16gb ram, intel iris 1536 mb graphics card. It loads into the game after a little, but I can’t play a game. When it loads into any game type, including tutorial, it loads into the game and all can see is the map. I can scroll over and see health bars pop up for things, but they aren’t visible. What do I need to do?

  8. Same thing here, I have 2013 macbook pro, 2,5 GHz Quad-Core Intel Core i7, 16 GB RAM, NVIDIA GeForce GT 750M 2 GB and main menu is fine but when game is started I can only see map background with no buildings/units/structures. Here is the screenshot https://snipboard.io/mgq6Mt.jpg

  9. Exact same problem here.

    MacBook Pro (Retina, 15-inch, Mid 2014)
    2.8 GHz Quad-Core Intel Core i7
    16 GB 1600 MHz DDR3
    NVIDIA GeForce GT 750M 2 GB

    Porting Kit Version 4.1.17 (4.1.17)

  10. We fixed that for Nvidia and and Intel iris GPU’s in the experimental mode (go to preferences –> select experimental mode and restart porting Kit) then reinstall the complete port (delete the game first from porting Kit). We will implement it to the main PK branch very soon.

  11. We fixed that for Nvidia and and Intel iris GPU’s in the experimental mode (go to preferences –> select experimental mode and restart porting Kit) then reinstall the complete port (delete the game first from porting Kit). We will implement it to the main PK branch very soon.

  12. Hi Paul! I have the following question. I installed the AoE II Definitive Edition without problems using Porting Kit + Steam. I can play the game, but the multiplayer option does not work. Do you know how can I fix this? Thank you very much!

  13. Hey Paul,
    does it also work on:
    macOS Big Sur
    Version 11.4
    MacBook Pro 13″ 2020
    2 GHz Quad-Core Intel Core i5
    16 GB 3733 MHz
    Intel Iris Plus Graphics 1536 MB
    Thank You very much for your response!

  14. Hi there, couldn’t get Age of Empires 2 to load after installing. I’m not much of a tech guy and your solution was the closest I’ve gotten to playing this game. I’m running an older Mac mini, these are my specs :
    Sierra, 10.12.6, 2.7 Intel Core.
    This is the error I received right near the end of installing the game:
    The Installation failed. Failed to download the Wineskin Master Wrapper: Cannot read property ‘toLowerCase’ of undefined. This happened when I had to choose folder to save Wineskin. default option wouldn’t let me install to default directory, so I created a new folder on desktop and chose to save there, then the installation failed. Any way, I was so close to being able to play this game I got excited. Using your app was pretty intuitive, you have made it the easiest by far, the problems could be with my Mac as well, may be impossible to determine.
    Thanks for all your hard work making this possible.

  15. Hi,

    I get stuck on a black screen with the aoe cursor displayed but can proceed. any suggestions?

  16. When running into issues. Please contact us using the Portingkit app. Then we can provide individually support.

  17. I tried the instructions, but AOE 2 DE does not launch. Everything installs perfectly and no error messages are thrown. This is on a fully maxed out M1 Max 16″ MBP.

  18. I think upgrading to Mac OS Monterrey made the game run slow. It doesn’t matter if I have it on Ultra or Low settings, the game seems to fluctuate from 20-30fps to over 60fps. Even at the start of a game with minimum units. Anyone else experiencing this? Should I reinstall the game through Porting Kit?

  19. The instructions are not as straight forward as they seem. You have to press “play” in steam multiple times to get DE to launch. Sometimes a restart helps, sometimes it does not. It may take 10-15 tries to get the game to launch. I can’t figure out a pattern, but if someone does, please let us all know!

    Brandon: I have no performance issues in Monterey. But then again, this is a fully loaded M1 Max 16″

  20. i got this error anyone able to help tnx

    ERROR: File SteamSetup.exe needed by winetrick steam failed to download: Downloaded file doesn’t match expected hash
    Error: File SteamSetup.exe needed by winetrick steam failed to download: Downloaded file doesn’t match expected hash
    at _0x35f331. (/Applications/Porting Kit.app/Contents/Resources/app.asar/appo/installer/app.js:1:930139)
    at /Applications/Porting Kit.app/Contents/Resources/app.asar/appo/installer/app.js:1:903189
    at Object.throw (/Applications/Porting Kit.app/Contents/Resources/app.asar/appo/installer/app.js:1:903414)
    at _0x4a15cb (/Applications/Porting Kit.app/Contents/Resources/app.asar/appo/installer/app.js:1:900577)

  21. Hi everyone, I managed to install everything without any problem. However when I click play in steam, it will just trying launching the game, but eventually it will just stop and will not start with no error message. I’ve tried both normal and experimental porting kit mode with the same result. Any hint on what might be the issue?

  22. Hello, with OS Monterey, has anyone able to play AOE2: DE in multiplayer getting out of sync error as soon as the game starts in 10 sec

  23. Hi, got the same error as Addy, sync error after appr. 1min in multiplayer…

    Are there any fixes?

  24. Same for me — desync about ten-fifteen seconds in. It feels like it’s just a configuration thing since I can play single player and join a lobby totally fine.

  25. Same here on m1/Monterey 12.5. Any help would be appreciated – my son is so sad we can’t play since I upgraded my mac!

  26. Same issue here. Everything works just fine, but mulitplayer gets out of sync every game after like 10 seconds. So it is working fine for the start and then there is this error. Anyway to fix it?

  27. Same issue here, It has to be a configuration thing. Everything works perfectly until the multiplayer game starts.

  28. Been trying to get this to work for a couple hours using Porting King. Followed all of the steps but at the end of the install it asks me to select my age of empires exe file which I don’t have. I have it purchased on steam but I can’t download an exe file. It says that it was successful but clinking on the game icon after installing does nothing.

  29. I have the same problem in multiplayer. After a short time the synchronization error occurs. The problem does not occur when only two porting kits are playing together. As soon as a player with “real” Windows is in the game, the game stops after about 40 seconds with the same error. Winetrick tips concerning a DLL led to the fact that we could not play together any more, because suddenly the game versions were different.

    Translated with http://www.DeepL.com/Translator (free version)

  30. Hi Paul, I’ve been playing AoE2 DE via Steam and Wineskin on my Mac Studio & Studio Display for a several months now and it has been working great. However on one startup yesterday, AoE2 presented a box asking for computer control permission, (Accept/Deny). It might’ve appeared after a Steam or AoE2 update, I forget. Unfortunately I clicked “Deny” not knowing what it meant. Now every time I start the game, Steam loads fine but then AoE2 DE displays a very small windows type dialog box which says “Screen Resolution must be at least 1024×720, with only an OK button which closes the box. Obviously my Mac Studio display has a high enough resolution. How do I get AoE2 to see that? In the AoE2 dialogue box there is no option or settings choice to change the screen resolution, (the box is vary small). Is there some hidden AoE2 DE settings file I should delete to reset AoE2 DE back to the correct parameters for the desired screen resolution? (The Settings Control Panel on my Mac is of no help).

  31. After a recent AOE2 patch the game will no longer start up. I press the play button in the Steam app, the button turns to stop, but after a short period of start up the button returns to displaying Play. So the game doesn’t start up.

  32. Same issue as Andrew – wrapper may need an update to allow it to work with new patch?

  33. Hi Paul, Unfortunately, I also have the same issue with AoE2 DE (via Steam and Wineskin on my Studio Mac w/OS Ventura 13.5) as Andrew. While Steam seems to load properly, when I open the game itself, it briefly tries to open for about 15 seconds but then quits and acts as if it was never opened. I never get to a point where I see any sort of AoE2 game screen. I do get a dialog box asking me if want to “Open Steam” with a button to click yes. (Even though Steam should already be open?). However, in both cases, either clicking the button or not, AoE2 DE does the same thing, it tries to open and then quits. Any ideas? At this point I’m thinking of trying CodeWeaver’s Crossover software. Not sure what to do. Thanks for any suggestions…

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.