Gobliiins Triology Wrapper update!

Made a wrapper update for Gobliins Triology as well! This one wasn’t OSX 10.8.2 compatible yet and I added a new paulthetall.com branded icon as well.

Changes:
OSX 10.8.2+ compatible
– New paulthetall.com branded Icon

Download the new wrapper from the game page up here…

gobliiins

Comments are closed.