Gothic 2 Wrapper update!

There was mentioned a problem on the forums about launching Gothic 2 and about getting an error message after the intro, so even though I did not had the issue myself, I updated the wrapper with a fix for that :) So if you don’t own Gothic 2 yet, you can get it from GOG.com and install it into the wrapper. If you already owned the game and experienced any issues in the latest wrapper, then try this one. Have fun!

Changes:
– Issue with crash after intro (if you had one) into the wrapper should be fixed.
– Paulthetall.com branded Icon

Get the new wrapper from the game page up here…

gothic 2

Love the work we do? Become a Patron… and get extra Tiers!

Leave a Reply